ECU & Electronics Discuss electronics and related components within.

96 camry no start

  #1  
Old 01-01-2015, 03:47 PM
Junior Member
Thread Starter
Join Date: Jan 2015
Posts: 2
Default 96 camry no start

Hope this is in the right area. I have a 96 camry that just cranks. Tested spark plugs n got no spark. Distributor, cap, rotar are replaced. Coil pack replaced. Ignition module replaced. Still just cranks. Tried starting it with starter fluid and it just cranked. What shold I check next?
 
  #2  
Old 01-01-2015, 04:31 PM
Super Moderator
Join Date: Jan 2008
Location: PTW
Posts: 11,742
Default

What engine, V6 or 4-cylinder?

The engine have a remote cam or crank sensor?

Check for +12v at the coil pack and ign module (black/red wires).

Check for broken timing belt. Crank engine and view rotor for rotation.
 
  #3  
Old 01-01-2015, 10:52 PM
Junior Member
Thread Starter
Join Date: Jan 2015
Posts: 2
Default

4 cylinder rotor does turn timing belt is good. The coil and ign module are new but the ign module is not getting power if I remember correctly. Engine light is on hooked it up and throwing a code for the ign module. Couldn't clear the code. Would u say the ecm is bad.
 
  #4  
Old 01-02-2015, 12:34 PM
Super Moderator
Join Date: Jan 2008
Location: PTW
Posts: 11,742
Default

Ign module not getting 12V power or ECM power?

What is the code number?

Does the engine have remote cam or crank sensor. Are the sensors built into the distributor or is one or another located off the timing belt pulley (timing cover area)?
 

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.