Engine Hesitation and Clicking during acceleration and up hills - Camry Forums - Toyota Camry Forum

Go Back  Camry Forums - Toyota Camry Forum > Your Ride > Engine & Internal
Reload this Page >

Engine Hesitation and Clicking during acceleration and up hills

Engine & Internal Chat about beefing up your engine's insides here.

Engine Hesitation and Clicking during acceleration and up hills

Reply

 
 
 
  #1  
Old 03-11-2018, 01:36 PM
Junior Member
Thread Starter
Join Date: Aug 2017
Posts: 9
Default Engine Hesitation and Clicking during acceleration and up hills

So I recently started having a problem of lack of acceleration and power. Sometimes Ill be going up a hill and all of the sudden I try to accelerate and the engine just isnt giving any power. Ill hear one or two strange clicks and then Ill let off the gas until Im not on a hill anymore. Once Im on flat ground for the most part it doesnt do it, but it has occasionally.

I thought maybe it was the spark plugs so I changed the front 3 (2001 V6 XLE). I didnt see any difference so I figured there wasnt much reason to take the time to change the others at this point. Then I thought maybe it was an oxygen sensor since my mileage in the city went down from around 18 down to 13 mpg. But I drove it on the highway and got 27 mpg, so I dont think thats it.

I dont want to invest too much into it anyway because it has a lot of miles anyway. But if its something I could do myself, it'd be nice to have it fixed. Any suggestions would be helpful. Thanks
 
Reply With Quote
  #2  
Old 03-12-2018, 11:57 AM
Super Moderator
Join Date: Jan 2008
Location: PTW
Posts: 11,157
Default

When you are going up a hill? Does the transmission kick down to a lower gear?

What is the RPM when going up hill?

Any trouble codes or pending trouble codes?
 
Reply With Quote
  #3  
Old 03-12-2018, 12:48 PM
Junior Member
Thread Starter
Join Date: Aug 2017
Posts: 9
Default

It does shift down to a lower gear but rpm's stay the same as I try to accelerate. No check engine light is on. It dont think its the transimission mainly because of the sounds I hear when it occurs. It doesnt sound like the engine is working hard. Almost like a sputtering noise and no acceleration.
 
Reply With Quote
  #4  
Old 03-13-2018, 11:37 AM
Super Moderator
Join Date: Jan 2008
Location: PTW
Posts: 11,157
Default

Any trouble codes or pending codes?

An engine problem can appear first when the engine is required to produce more HP such as going up a hill.

The sputtering could be an engine miss.

A common issue is bad ignition coils or ign wires. This problem tends to cause the check light to come on due to misfire and rich mixture.

A plugged fuel filter or failing fuel pump can result in lack of power. These may or may not set a trouble code.

Check your overall MPG again. If it did drop from 18 to 13 mpg. A failing O2 sensor can cause decreased MPG and a miss under load. This is a common issue.
 
Reply With Quote
  #5  
Old 04-08-2018, 06:40 PM
Junior Member
Thread Starter
Join Date: Aug 2017
Posts: 9
Default

I finally decided to change the back 3 plugs ( which wasnt as hard as I had thought) and the problem seems to be fixed. I've only driven it about 20 minutes around town so far but right now it feels like Im driving a different car. Ill post again if anything changes. Thanks for the tips!
 
Reply With Quote
  #6  
Old 04-08-2018, 07:30 PM
Super Moderator
Join Date: Jan 2008
Location: PTW
Posts: 11,157
Default

Good job!

Keep us posted.
 
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
JOHNNYUK
DIY - Do It Yourself
8
02-20-2011 06:52 AM
Camryboy_sa
General Tech
0
04-02-2010 11:45 AM
rkimes11
General Tech
9
02-21-2010 05:40 PM
ckelner
General Tech
2
04-20-2009 07:09 PM
91 toyota
General Tech
6
12-27-2007 10:45 AM


Thread Tools
Search this Thread