General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

99 Camry 3.3 ac issue

  #1  
Old 07-07-2019, 06:57 PM
Junior Member
Thread Starter
Join Date: Feb 2018
Posts: 6
Default 99 Camry 3.3 ac issue

My camry ac is not blowing cold, t-stat was changed and cooling system flushed. AC worked fine today it just blew out cool not cold like it had been. I checked the freon and it is full(checked with Manifold gauge. Any ideas? Someone mentioned that the resistor might been the issue but I thought that was just for blower fan speed.
 
  #2  
Old 07-08-2019, 05:52 AM
Junior Member
Thread Starter
Join Date: Feb 2018
Posts: 6
Default

Sorry 3.0
 
  #3  
Old 07-08-2019, 03:36 PM
Super Moderator
Join Date: Jan 2008
Location: PTW
Posts: 11,738
Default

Did you check high/low pressures?

Resistor is for blower speed but should have high speed even if bad.

Any chance the evap coil is plugged with debris, air door problems, etc.
 
  #4  
Old 07-08-2019, 08:51 PM
Junior Member
Thread Starter
Join Date: Feb 2018
Posts: 6
Default

I checked low side only, blower works fine which leads me to believe that the resistor is fine. Did not check for debris yet though.
 

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.