New Member Area New to Toyota Camry Forums? Stop in tell us about you.

92 camry loses fuel signal

  #1  
Old 09-07-2011, 08:02 PM
Junior Member
Thread Starter
Join Date: Sep 2011
Posts: 5
Default 92 camry loses fuel signal

I have A 1992 toyota camry 2.2 engine ,it runs great for 30 to 40 minutes then it dies.I can spray fuel in and it runs for a few seconds,if it sets for a while and cools off it starts up and does it all over again. I put a new fuel pump in and it does the same thing , it acts like the injectors quit until it cools off, any advice would be great .
 
  #2  
Old 09-08-2011, 12:33 AM
Senior Member
Join Date: Sep 2008
Posts: 965
Default

I guess it runs out of fuel for a few mins...seems like engine problem to me.
 
  #3  
Old 09-08-2011, 12:40 AM
Senior Member
Join Date: Sep 2008
Posts: 965
Default

Try to check the fuel pressure a fuel pressure guage would be helpful, also check the ignition coil , lastly check for ang error codes.
 
  #4  
Old 09-08-2011, 09:47 AM
Super Moderator
Join Date: Jan 2008
Location: PTW
Posts: 11,742
Default

Look inside the engine compartment, passengers side strut mount tower for a small black plastic box. Inside the box are electrical terminals. Use a section of electrical wire to connect the FP and B+ terminals.

Doing this will bypass any relays, etc in the fuel pump wiring. The fuel pump will now run continuously when the ign key is on.

Use a section of rubber hose as a stethoscope to listen to the injectors when engine running. They make a pretty loud click. If the engine does not start listen to the engine when the engine is cranking over to determine if they are working.
 
  #5  
Old 09-08-2011, 06:39 PM
Junior Member
Thread Starter
Join Date: Sep 2011
Posts: 5
Default

I crossed terminals pump did run continuously,but the injectors do not click.I had to let the car run for 50 minutes before it quit today.
 
  #6  
Old 09-09-2011, 10:46 AM
Super Moderator
Join Date: Jan 2008
Location: PTW
Posts: 11,742
Default

Check if the injectors are receiving DC power.

Each injector has two wires, one wire always receives power when the ign switch is on. The other wire is the ground wire to complete the circuit. This wire runs to the computer.

The computer activates the injector by completing the ground wire circuit.

Power wire might be Black/Orange or White/Red.

Ground wires Yellow, White, or Red/Black.

Note: more then one injector may have the same ground wire as the injectors can be wired to operate in pairs.
 
  #7  
Old 09-09-2011, 06:41 PM
Junior Member
Thread Starter
Join Date: Sep 2011
Posts: 5
Default

Well today I let the car run for 2hr 45 min it ran fine. I will try again tomorrow and let you know what happens. Thanks for all your help toyomoho.
 
  #8  
Old 09-10-2011, 03:56 PM
Junior Member
Thread Starter
Join Date: Sep 2011
Posts: 5
Default

The camry ran great today until I shut it off, then no restart. I checked the voltage at the injector on number one cylinder it had 12 volts on the white with red stripe and 12 volts on the white with black stripe , but when I did the white with black stripe the number 3 cylinder injector clicked ?
 
  #9  
Old 09-10-2011, 08:25 PM
Super Moderator
Join Date: Jan 2008
Location: PTW
Posts: 11,742
Default

No 1 and 3 injectors share the same wire going to the computer. They would fire at the same time.

Voltage can be 9-14 volts after the injector.

Does the engine have ign spark?
 
  #10  
Old 09-10-2011, 10:04 PM
Junior Member
Thread Starter
Join Date: Sep 2011
Posts: 5
Default

Yes car will run if you spray with starting fluid.
 

Thread Tools
Search this Thread
Quick Reply: 92 camry loses fuel signal


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.