New Member Area New to Toyota Camry Forums? Stop in tell us about you.

98 Camry 4 cyl rough idle when hot

  #1  
Old 02-28-2012, 06:33 PM
Junior Member
Thread Starter
Join Date: Feb 2012
Posts: 5
Unhappy 98 Camry 4 cyl rough idle when hot

I need advise on a 98 Camry 4 cyl with about 150k on it. When cold it idles and runs fine. I think the IAC is working because you get a noticeable incr in RPMs when turning on AC. When the engine warms up it idles rough and the RPM wanders, sometime almost stalling. It is worse with the AC on. I checked the resistance of the IAC per Haynes manual, 20 ohms from each side to center pin. I also sprayed some cleaner in the IAC port in the throttle body, which seemed to help, but not much. There is no check engine light on. Plugs and plug wires were changed about a year ago.
 
  #2  
Old 02-29-2012, 09:52 AM
Super Moderator
Join Date: Jan 2008
Location: PTW
Posts: 11,620
Default

The IAC valve responds to signals from the computer. One signal is coolant temp. Check the coolant temp sensor for the computer.
 
  #3  
Old 02-29-2012, 12:16 PM
Junior Member
Thread Starter
Join Date: Feb 2012
Posts: 5
Default

Is that different than the sensor that operates the temperature guage?
 
  #4  
Old 02-29-2012, 12:43 PM
Super Moderator
Join Date: Jan 2008
Location: PTW
Posts: 11,620
Default

Yes, look on a manifold where the upper coolant hose attaches to the engine. Should be several sensors. The engine sensor has 2 wires may be green/black and brown. The gauge sensor typically has only one wire.
 
  #5  
Old 02-29-2012, 06:01 PM
Junior Member
Thread Starter
Join Date: Feb 2012
Posts: 5
Default

Well, in your opinion does that make sense? I have been looking at various websites about the IAC valve and all the problems it makes. The fact that mine increases RPMs when cold if you turn on the AC makes me think it must be working and something else is causing this. The IAC looks rather nasty to get off for cleaning or replacement, I have the 4 cyl engine. There are no other symptoms or indications (no check engine light). It runs perfectly at low or high speed. Just a stumbling uneven idle when hot, with or without AC, but worse with AC.
 
  #6  
Old 03-01-2012, 10:24 AM
Super Moderator
Join Date: Jan 2008
Location: PTW
Posts: 11,620
Default

Don't take the IAC off. Do an internet search on cleaning the IAC valve for your engine model, this is a common subject.

The AutoZone website may have info on checking the coolant temp sensor using an ohm meter. Check in the sites vehicle repair guide section for your make of car.
 
  #7  
Old 03-05-2012, 05:16 PM
Junior Member
Thread Starter
Join Date: Feb 2012
Posts: 5
Default

Well, I replaced the temperature sensor, but no luck, still the same. I tried cleaning the IAC valve (without removing it) by squirting throttle body and sensor safe cleaner into the port right in front of the throttle butterfly, and that did not help either. When cold it idles perfect, but when hot it idles down to around 500-600 rpm, and stumbles intermittently, like one cylinder doesn't fire. You can see the rpms drop when that happens. Is the IAC the only itme that controls idle speed? There is no check engine light, and I took it to a shop, there are no stored error codes.
 
  #8  
Old 03-05-2012, 06:56 PM
Senior Member
Join Date: Sep 2008
Posts: 965
Default

check this vid on way how to clean IAC valve

How to Clean the IACV- Idle Air Control Valve - YouTube
 
  #9  
Old 03-05-2012, 09:07 PM
Super Moderator
Join Date: Jan 2008
Location: PTW
Posts: 11,620
Default

If the idle drops too low the engine will shake a lot.

Is the problem limited to idle RPM issues or does the engine have lack of power or a miss when driving (higher RPM's).

The IAC valve controls idle. It is connected to the engine coolant system thus it can respond to coolant temps (hot or cold).

If the problem is limited to the idle then would explore the IAC valve.

Or perhaps some kind of strange vacuum leak issue.
 
  #10  
Old 03-13-2012, 06:10 PM
Junior Member
Thread Starter
Join Date: Feb 2012
Posts: 5
Default

In case others are following this thread I wanted to update. The low and wnadering idle speed was indeed the IAC valve. I tried spraying clear in the port in the front of the throttle body with little success. Saturday I tore everything apart and gave the IAC and throttle body a thorough scrubbing...which completely fixed the idle issues. The miss was a bad spark plug. Put in a new set and it purrs like a kitten. Thanks for your help.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
citzen7143
General Tech
1
06-18-2012 12:02 AM
hardyrxp
Engine & Internal
7
02-08-2011 06:07 AM
jmhowe
New Member Area
1
10-24-2006 03:49 AM
green97le
General Tech
2
06-08-2006 12:32 AM


Thread Tools
Search this Thread
Quick Reply: 98 Camry 4 cyl rough idle when hot


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.