Audio/Visual Electronics Wired up? Everyone's got some sort of electrical modification. let's hear about it here.

'99 Tape Player

  #1  
Old 06-22-2012, 08:45 PM
Member
Thread Starter
Join Date: Oct 2011
Posts: 35
Default '99 Tape Player

When I try to use my stock tape player, it makes a loud clicking sound the entire time, and it stops, reverses itself, and then continues as well. Also, I have to try to re position the tape so that the audio actually plays on all speakers. Any ideas what the problem could be or any tips to try to fix this issue?

Thanks for any help you can give

-Kevin
 
  #2  
Old 06-24-2012, 11:58 AM
Super Moderator
Join Date: Jan 2008
Location: PTW
Posts: 11,741
Default

Can't answer all of your issues however the plastic gears that drive the tape mechanism do crack resulting in a constant clicking noise.

Most owners opt for a replacement after market player rather then attempt fixes due to lack of available parts and repair cost.
 
  #3  
Old 06-25-2012, 04:45 PM
Member
Thread Starter
Join Date: Oct 2011
Posts: 35
Default

I didn't even think about that, thanks for the info Joey!
 
  #4  
Old 06-27-2012, 09:50 PM
Senior Member
Join Date: Sep 2008
Posts: 965
Default

maybe the problem is with the tape itself.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
TonyJ
General Tech
2
07-20-2012 12:14 AM
Camry84
Audio/Visual Electronics
2
11-13-2011 08:47 PM
gingerfuzz
Audio/Visual Electronics
4
10-14-2008 04:47 AM
madgame111
PRIVATE For Sale / Trade Classifieds
2
01-25-2006 08:12 PM


Thread Tools
Search this Thread
Quick Reply: '99 Tape Player


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.