ECU & Electronics Discuss electronics and related components within.

Airbag and horn not working!

  #1  
Old 01-07-2016, 09:13 AM
Junior Member
Thread Starter
Join Date: Jan 2016
Posts: 4
Default Airbag and horn not working!

Hello all! Just had the rack and pinion replaced on my'98 Camry with 216K on it. When I got it back the airbag light was on and the horn doesn't work. Airbag light has never come on before except the usual when starting the car and horn had always worked. Did my mechanic disconnect something and forget to put it back together? Any ideas would be greatly appreciated, thanks!
 
  #2  
Old 01-07-2016, 12:11 PM
Senior Member
Join Date: Jan 2014
Location: Ipswich QLD australia
Posts: 543
Default

The Fix
now needs a proper diagnostic scanner to clear the fault code or find the cause of the fault


at high risk of deployment of the bag while you are undoing these systems
you are never to remove the steering wheel with the battery connected

a possible cause

some workshops undo the steering wheel to undo the spline nut ... remove the steering wheel and re align the spline re tighten
so the steering wheel faces straight across so the indicators cancel out as you corner

you can break the clock spring in the air bag system

sounds like the battery was not disconnected
or they forgot to reconnect the horn air bag plug
or a fuse

are the indicators other column stalk devices working

if not a fuse

take it back to them
 

Last edited by dirty hands; 01-07-2016 at 12:18 PM.
  #3  
Old 01-07-2016, 12:14 PM
Junior Member
Thread Starter
Join Date: Jan 2016
Posts: 4
Default

Yep everything else works, weird about the horn, is it on the same fuse as the airbag?
 
  #4  
Old 01-07-2016, 12:19 PM
Senior Member
Join Date: Jan 2014
Location: Ipswich QLD australia
Posts: 543
Default

a horn has its own fuse

air bag works on a different circuit and more complex through the ECU
 

Last edited by dirty hands; 01-08-2016 at 05:41 AM.
  #5  
Old 01-07-2016, 12:21 PM
Junior Member
Thread Starter
Join Date: Jan 2016
Posts: 4
Default

Why would they both go a wall at the same time, coincidence?
 
  #6  
Old 01-07-2016, 12:23 PM
Super Moderator
Join Date: Jan 2008
Location: PTW
Posts: 11,742
Default

Check if the cars hazard lights (emergency flashers) work. If so check if the HORN fuse is blown. Its location is in a relay/fuse box inside the engine compartment drivers side. If OK the horn system should have power.

Find out if the mechanic removed the steering wheel. If so, they may have failed to reconnect the horn and steering wheel airbag to the wiring or damaged the wiring. If the airbag is not connected the airbag light will illuminate.

You can find out if the issue is the steering wheel airbag by connecting a code reader to the cars OBDII diagnostic system. With the light on, a trouble code has been set. The code reader will read out this code which will pin point the location of the problem, as in perhaps a steering wheel airbag fault.

Suggest you return to the mechanic and voice your concerns. They can check the trouble codes.

If the airbag light is on, the airbag system is off and will not work if needed.
 
  #7  
Old 01-07-2016, 12:45 PM
Junior Member
Thread Starter
Join Date: Jan 2016
Posts: 4
Default

Hazards work, all fuses fine, do back in the shop she goes! Thanks for the advice I'll let you know what happens.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
milowilli
General Tech
11
08-16-2017 09:01 PM
Saeed Ahmed
New Member Area
1
02-06-2013 01:01 PM
mx3man83
ECU & Electronics
5
07-04-2009 11:24 PM
marv8
General Tech
1
10-17-2007 08:11 AM
victorcay
General Tech
1
05-04-2007 11:04 AM


Thread Tools
Search this Thread
Quick Reply: Airbag and horn not working!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.