Engine & Internal Chat about beefing up your engine's insides here.

Spark plug questions

  #1  
Old 05-28-2016, 09:06 AM
Junior Member
Thread Starter
Join Date: May 2016
Posts: 19
Default Spark plug questions

Hey all,1994 Camry 2.2 4cyl with 146,000 miles. I got the car in 2011 with 72,054.

Now my questions are: I had a bad stalling problem did a million things to try and help,not much did. I took it to a trusted shop and all they did was change the plugs/wires. Didn't stop the stalling either. That plug change came at 114,329. SO It's been 31,769 since the plugs have been changed. Is it time to change??

My car runs rough,bad acceleration,vibration,emission smh at times,hesitation when letting off pedal. I've changed both the sender switch and the ect switch. Cleaned my throttle body,IAC valve,intake valves,some of egr valve and cleaned the crud on basically everything.

I'm going to check the plugs gap/condition I'm just wondering if there's a rule of thumb for changing plugs in terms of miles etc. Thank you all so much,love this site/forums.
 
  #2  
Old 05-28-2016, 03:45 PM
Super Moderator
Join Date: Jan 2008
Location: PTW
Posts: 11,739
Default

What is the plug number?

Factory plugs should go 80K-100K miles.

If you check the ign system as in the actually spark quality?

How about fuel? Do all spark plugs electrodes look the same?
 
  #3  
Old 06-01-2016, 07:34 AM
Junior Member
Thread Starter
Join Date: May 2016
Posts: 19
Default

I checked em out and they definelty needed to be changed,the electrodes were basically gone,grey crust and on one of them (4th cyl) the ceramic had brown fluid or something all over it,maybe oils.

It's interesting with the new plugs my acceleration is better,pick up etc especially 40-50mph. Now when I get up to highway speeds around 65 the rpms seem to almost not move down. It's not rough it's like the car will gradually and nicely go up to 60-65 go to 3000 rpms or so and while I'm maintaining these speeds the rpms will stay at 2000,(which I think is normal). The thing is when I take my foot off the pedal the rpm doesn't really move down until under 60.

Is this normal? I'm thinking maybe Im noticing it because the car hasn't run well in a while. Could it be adjusting to the bee plugs and wires?. It def runs better just this little thing I noticed. Thanks
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
manty1
ECU & Electronics
5
04-10-2013 04:54 AM
nodrogkam
General Tech
4
01-26-2007 12:50 AM
santolucha
General Tech
2
01-23-2007 12:38 AM
Sparkplugs.com
General Tech
1
12-19-2006 01:08 AM
sl1solo
General Tech
4
08-08-2006 06:31 PM


Thread Tools
Search this Thread
Quick Reply: Spark plug questions


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.