New Member Area New to Toyota Camry Forums? Stop in tell us about you.

2010 VTT-I Wont Accelerate (Help)

  #1  
Old 02-06-2018, 05:17 PM
Junior Member
Thread Starter
Join Date: Feb 2018
Posts: 3
Angry 2010 VTT-I Wont Accelerate (Help)

Hello all,
I'm trying to fix my moms 2010 Camry VTT-I (73K miles). I test drove the car and it will not accelerate pass 10 MPH at best. I press the gas and the RPM didn't move with the transmission in the parked position. I checked the EFI 10A and 25A fuse and no shortage.

Someone mentioned the throttle body position sensor could be bad. I tried researching where the throttle body position sensor to replace but "CAN'T" locate it anywhere. I did find the throttle body but have no idea where the sensor is located. Every video I've found does not show images of the same or similar 2010 Camry VTT-I engine compartment.

Any suggestions or recommendations would be extremely helpful. Thanks in advance

Very Respectful

JN
 

Last edited by janashjr; 02-06-2018 at 05:23 PM. Reason: added additonal informartion milage
  #2  
Old 02-07-2018, 02:31 PM
Super Moderator
Join Date: Jan 2008
Location: PTW
Posts: 11,682
Default

Have you check all fuses including ETCS?

It is possible the motor for the throttle plate in the throttle body has failed. Or the gas pedal sensor which tells the computer the position of the gas pedal.

When this happens the engine goes into limp home mode.

Is the check engine light on?
 
  #3  
Old 02-07-2018, 06:02 PM
Junior Member
Thread Starter
Join Date: Feb 2018
Posts: 3
Default

Hello Toyo
First thanks for the reply. Yes I checked all the fuses in the electrical box under the hood and none where blown. Now thinking about it I didnít check any fuses inside the vehicle. I agree that it maybe 1 of 2 issues the gas pedal assesmbly and/or throttle body. I called Toyota and the throttle position sensor is not separated anymore and must buy the entire throttle body. Yes, the check engine light is on.
So, I ordered the gas pedal assembly since it was the least expensive of the two. Once installed if not working then Iíll have to breakdown and purchase the throttle body as well. Meanwhile, Iím going back out to check the internal fuse box and will post the out come. Thanks again!
 
  #4  
Old 02-07-2018, 06:52 PM
Super Moderator
Join Date: Jan 2008
Location: PTW
Posts: 11,682
Default

If check light on, a trouble code is stored. This code can narrow down the problem part.

For the TB, shop aftermarket parts vrs dealer to save $.
 
  #5  
Old 02-09-2018, 01:23 PM
Junior Member
Thread Starter
Join Date: Feb 2018
Posts: 3
Default

Toyomoho
I purchased the Innova code reader 3040 and received code P2118. I have since my last thread replaced the positive battery cable, new battery was installed January 2018 (less than 1 month ago) and awaiting for the pedal assembly sensor from the parts store to arrive. Once it arrives on Saturday, I'll install and provide feedback. Thanks again for your support and assistance.

V/r
JN
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
avande1882
Engine & Internal
5
06-01-2011 12:53 AM
noel_99camry
Engine & Internal
4
07-18-2009 03:46 PM
noel_99camry
General Tech
1
06-01-2009 07:08 PM
taxpayer
General Tech
1
11-17-2008 06:13 AM


Thread Tools
Search this Thread
Quick Reply: 2010 VTT-I Wont Accelerate (Help)


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.