Go Back  Camry Forums - Toyota Camry Forum > General Toyota Camry Forums > TCF Help & Suggestion Center
Reload this Page >

2007 Camry LE windshield wipers work on high and low but not mist or intermitten.

TCF Help & Suggestion Center Need help with Toyota Camry Forums? Ask. Have a suggestion to better TCF? Tell us here.

2007 Camry LE windshield wipers work on high and low but not mist or intermitten.

  #1  
Old 05-31-2017, 10:52 AM
Junior Member
Thread Starter
Join Date: May 2017
Posts: 2
Default 2007 Camry LE windshield wipers work on high and low but not mist or intermitten.

hey there I have an 07 Camry LE and the high and low option on the windshield wipers work. But the mist and intermitten options do not. The wipers will stop wherever they are when I turn off any option. I have got into almost taking off the wiper stalk/switch but not sure how to talk it off due to the clips or something. Could it be the switch/stalk or the actual motors of the windshield wipers? Thanks
 
  #2  
Old 06-01-2017, 12:12 AM
Super Moderator
Join Date: Jan 2008
Location: PTW
Posts: 11,739
Default

Make sure the mist pump is not running and its not just a plugged line, etc.

Check the WASH fuse which powers the pump.

When mist is engaged, the column control unit grounds the wire from the pump to complete the circuit. Gray wire.

The motor unit has a mechanical switch that opens/closes by a rotating cam attached motor gearing. This switch is what positions the wiper arm in the correct parking place.

Typically if not parking, the switch arm has broken off.

You can check the switch operation with a meter. There should be continuity between the Black and White/Black wires when the arm is parked in the correct position.
 
  #3  
Old 06-01-2017, 01:06 AM
Junior Member
Thread Starter
Join Date: May 2017
Posts: 2
Default

Originally Posted by toyomoho View Post
Make sure the mist pump is not running and its not just a plugged line, etc.

Check the WASH fuse which powers the pump.

When mist is engaged, the column control unit grounds the wire from the pump to complete the circuit. Gray wire.

The motor unit has a mechanical switch that opens/closes by a rotating cam attached motor gearing. This switch is what positions the wiper arm in the correct parking place.

Typically if not parking, the switch arm has broken off.

You can check the switch operation with a meter. There should be continuity between the Black and White/Black wires when the arm is parked in the correct position.

I didn't see anything broken when I got to the wiper motor today. The options that work are high and low but when I switch either off it still stops at whatever point it is at. The intermittent option does not work at all. The mist will work but the wipers won't move at all. I will have to push the switch up to move the wipers myself from inside the car and hope to get the to the resting position. Could it be the actual switch/stalk?
 
  #4  
Old 06-01-2017, 10:37 AM
Super Moderator
Join Date: Jan 2008
Location: PTW
Posts: 11,739
Default

Understand.

If mist motor works when the button is pressed, assume the switch in the motor is the problem.

The parking switch is inside the motor gear box and not visible. That's why testing with a meter is required.

The parking switch tells the wiper system when the arms are at its parking spot. When the stalk switch is set to off. The wiper motor will continue operating until the arms reach their parking spot.

If the parking switch is not working. There is no way to tell when the arms are at their parking spot. When the stalk switch is turned to off. The wiper will stop at whatever their location is and not move to park.

The parking switch is required for the intermediate setting of the stalk switch to work. If there is a problem with the parking switch, the intermediate setting will not work.

The other wiper settings will still work. However the wiper arms will not move to park when the stalk switch is set to off.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Tonya
DIY - Do It Yourself
0
12-01-2014 06:02 PM
Tonya
ECU & Electronics
0
12-01-2014 06:00 PM
Player
General Tech
3
12-03-2008 06:03 AM
Player
General Tech
0
11-27-2008 01:17 AM


Thread Tools
Search this Thread
Quick Reply: 2007 Camry LE windshield wipers work on high and low but not mist or intermitten.


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.