ECU & Electronics Discuss electronics and related components within.

88 camry electrical nightmare

  #1  
Old 10-10-2014, 12:00 AM
Junior Member
Thread Starter
Join Date: Oct 2014
Posts: 4
Default 88 camry electrical nightmare

Hi everyone i have an 88 camry that wont start by the key so i jump out the solonoid and it runs and revs up perfect but when i put it in drive it wont accelerate or rev up.it moves just slow. The seatbelts and heater and windows also quit working at same time.car was perfect before so i highly doubt trans issues.any help would be amazing thanks.
 
  #2  
Old 10-10-2014, 12:39 AM
Patonium's Avatar
Super Moderator
Join Date: Nov 2013
Location: Maine
Posts: 1,223
Default

Did this happen all of a sudden or did it gradually become defiant? Any recent work done?
 
  #3  
Old 10-10-2014, 06:18 AM
Junior Member
Thread Starter
Join Date: Oct 2014
Posts: 4
Default

All at once.i bought it like this for super cheap.hoping its something stupid.
 
  #4  
Old 10-10-2014, 09:47 AM
Super Moderator
Join Date: Jan 2008
Location: PTW
Posts: 11,739
Default

You turn the ign key to start and nothing happens, so jump solenoid?

Do stop lights work?
 
  #5  
Old 10-10-2014, 05:01 PM
Senior Member
Join Date: Jan 2014
Location: Ipswich QLD australia
Posts: 543
Default

if key wont work it may still be the starter motor at fault

stuff not working
time to check the fuses in the engine bay and inside

next plugs and leads and timing - I guess - if labouring under load

drives slow
if it is an an automatic
sounds like the auto tranny has gone into fail safe - will only have third gear and reverse
if it is an auto - you can replace that tranny computer
 
  #6  
Old 10-14-2014, 06:34 AM
Junior Member
Thread Starter
Join Date: Oct 2014
Posts: 4
Default

It was the hidden fusible link coming from the battery fuses thanks everyone
 
  #7  
Old 10-14-2014, 07:46 PM
Super Moderator
Join Date: Jan 2008
Location: PTW
Posts: 11,739
Default

Good job in finding the problem. Thanks for posting back with the fix.
 
  #8  
Old 10-25-2014, 07:59 PM
Junior Member
Join Date: Nov 2013
Posts: 1
Default

zachfarmal,
I had a similar situation with my 91 Camry in September. In my case, the 80 amp main fusible link blew because of a electrical short to ground while I was driving. Everything except the engine died including warning lights - the engine still ran but slowed as the battery depleted. I barely made it home.

Two questions: Is the "hidden" link you mention the AM1 fusible link (black wire in series connected to the 80 amp main fusible link (on the white wire from the battery)? Also, after you replaced the fusible link, did it ever blow again? (My link keeps blowing due to the short, which I haven't yet located.)

Thanks - C-P
 
  #9  
Old 10-27-2014, 06:18 AM
Junior Member
Thread Starter
Join Date: Oct 2014
Posts: 4
Default

It was coming of the center 80 amp fuse it hidden in wiring harness
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
whathappenned
ECU & Electronics
3
12-18-2013 03:21 PM
wongleetoy
ECU & Electronics
1
08-11-2013 10:58 AM
timgren
DIY - Do It Yourself
4
04-03-2012 03:58 PM
happy420
General Tech
5
01-27-2010 08:37 AM
Jeytwo
General Tech
0
09-27-2008 10:13 PM


Thread Tools
Search this Thread
Quick Reply: 88 camry electrical nightmare


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.