ECU & Electronics Discuss electronics and related components within.

throttle position sensor

  #1  
Old 06-14-2010, 09:18 PM
Member
Thread Starter
Join Date: Feb 2010
Posts: 93
Default throttle position sensor

1993 Camry LE

I found a used TPS sensor at a junkyard for a 1994 Camry LE. They run about $80 new, so I thought I'd try the cheap route to solve my problem with the way my car is acting up, and bought this used one for $5.

it looks identical to mine on my 1993 Camry, but I later noticed that the part numbers are different..

does it matter that mine 89452-33010 is a different part number than the 1994 Model's of 89452-06010???

When I was at the salvage yard, I thought "if it's the exact same shape and look as mine, it should be the one I need". A bit hasty on my part, but it's the one I came home with and installed to have the car problem not go away!

help!
 
  #2  
Old 06-15-2010, 06:09 PM
Super Moderator
Join Date: Jan 2008
Location: PTW
Posts: 11,746
Default

Rockauto.com parts website has the same sensor part numbers listed for both years.

Why are you changing the sensor?
 
  #3  
Old 06-16-2010, 09:16 PM
Member
Thread Starter
Join Date: Feb 2010
Posts: 93
Default

I changed the Throttle Position sensor since I read that it might help with my acceleration/hesitation problme I'm working on at the moment..

I've replaced the Ign coil, coolant sensor and the TPS so far with some results, but the symptoms are still there...
 
  #4  
Old 06-17-2010, 09:17 AM
Super Moderator
Join Date: Jan 2008
Location: PTW
Posts: 11,746
Default

Hesitation or poor acceleration?

Have you checked the plugs and wires?
 
  #5  
Old 06-17-2010, 04:58 PM
Member
Thread Starter
Join Date: Feb 2010
Posts: 93
Default

Originally Posted by toyomoho View Post
Hesitation or poor acceleration?

Have you checked the plugs and wires?
It seems like I've done everything thus far!
replaced plugs, spark wires, cap & rotor, fuel filter, O2 sensor, coolant sensor, throttle position sensor (with a used one in good shape from a junkyard), cleaned EGR and IAC...

am going down the troubleshooting list to fix the acceleration and hesitation problem. It seems to smoothen out at 4K RPM's, but stutters and hesitates for the most part until higher RPM's...

I think I need to clean the EGR again or inspect closer for a vacuum leak somewhere.

I might have overlooked cleaning around the EGR piston thoroughly. Tonight, I'll try some Seafoam sprayed into the Brake booster vacuum line to clean injectors and freak out the neighbors with blue smoke. I think the injectors need cleaning since the O2 sensor and Coolant sensor were so worn out and had been on the car since when I bought the car with 95K miles (it has 260K miles now)...

you recommended checking fuel pressure, so I'll do that if the injector and EGR cleaning and vacuum leak check don't fix the problem..

any thoguhts??
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
stickshift
ECU & Electronics
1
06-05-2013 01:35 PM
umdaman
General Tech
2
02-24-2013 09:25 AM
Gen3Guru93
DIY - Do It Yourself
3
03-12-2012 08:37 AM
Mr Rumblur
ECU & Electronics
1
06-06-2011 10:27 AM
rt07
ECU & Electronics
4
01-11-2011 10:26 AM


Thread Tools
Search this Thread
Quick Reply: throttle position sensor


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.