Engine & Internal Chat about beefing up your engine's insides here.

2000 Toyota Camry XLE

  #1  
Old 02-22-2016, 05:12 PM
Junior Member
Thread Starter
Join Date: Feb 2016
Posts: 3
Default 2000 Toyota Camry XLE

I got my check engine light read a month ago and it read P0401 and P0402 so AAMCO checked it and replaced my EGR lift sensor. The light went away but two weeks later came back and a week after that my trac off light came on so now I have both light. What's wrong with my car? And how much do you think it will be?
 
  #2  
Old 02-22-2016, 09:26 PM
Super Moderator
Join Date: Jan 2008
Location: PTW
Posts: 11,742
Default

These codes are for the opposite issues with the same system - EGR.

Have the code(s) read out and post back. Depending on your state many auto parts stores will read the code(s) for free.

The trac light issue may be related to the check light issue. If the check light problem is fixed the trac light may turn off.
 
  #3  
Old 02-25-2016, 11:16 AM
Junior Member
Thread Starter
Join Date: Feb 2016
Posts: 3
Default

Originally Posted by toyomoho View Post
These codes are for the opposite issues with the same system - EGR.

Have the code(s) read out and post back. Depending on your state many auto parts stores will read the code(s) for free.

The trac light issue may be related to the check light issue. If the check light problem is fixed the trac light may turn off.
I just brought it to AAMCO and they said the code was P0420 and that it was a problem with the catalytic converter. And they said I would have to go to a special shop for that.
 
  #4  
Old 02-26-2016, 12:59 PM
Super Moderator
Join Date: Jan 2008
Location: PTW
Posts: 11,742
Default

The code is stating the converter is not working as it should.

Most likely the issue is the converter. But there is a chance it could be a bad 02 sensor or an exhaust leak. A good shop will be able to determine if it is the converter.
 
  #5  
Old 02-26-2016, 03:52 PM
Junior Member
Thread Starter
Join Date: Feb 2016
Posts: 3
Default

Originally Posted by toyomoho View Post
The code is stating the converter is not working as it should.

Most likely the issue is the converter. But there is a chance it could be a bad 02 sensor or an exhaust leak. A good shop will be able to determine if it is the converter.
I brought it to a shop and they said my back cat was empty. Like the filters and things were missing so they replaced the part
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
steveking
PRIVATE For Sale / Trade Classifieds
3
01-12-2016 06:36 PM
JOHNS
Suspension, Brakes, Tires & Wheels
1
08-12-2014 05:43 PM
liszt85
Suspension, Brakes, Tires & Wheels
0
08-23-2010 03:29 PM
XLE2000
New Member Area
2
07-28-2009 09:06 AM
srwhouston
Suspension, Brakes, Tires & Wheels
1
02-12-2008 07:09 PM


Thread Tools
Search this Thread
Quick Reply: 2000 Toyota Camry XLE


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.