Audio/Visual Electronics Wired up? Everyone's got some sort of electrical modification. let's hear about it here.

Amp went out in 2007 Camry w/ JBL System

  #1  
Old 09-03-2011, 05:20 PM
Junior Member
Thread Starter
Join Date: Sep 2011
Posts: 2
Default Amp went out in 2007 Camry w/ JBL System

Hey everyone,

So the other day my amp went out and I lost power to all my speakers excluding the tweeters up front. This is the stock JBL sound system and it has the amp underneath the passenger front seat.

I'm not sure what it was, but I'm assuming a fuse has blown. Does anyone know where/how to access this fuse so I can at least eliminate this variable from the equation and/or hopefully solve the issue simply and cheaply?

Any advice/input will be greatly appreciated!

Thanks,

-Alex
 
  #2  
Old 02-19-2012, 04:17 PM
Junior Member
Join Date: Feb 2012
Posts: 7
Default

Had the same problem. Check my post on2/19/2012. bad_smoke
 
  #3  
Old 02-23-2012, 02:29 PM
Junior Member
Join Date: Feb 2012
Posts: 5
Default

ya iam also facing the same problem
 
  #4  
Old 02-24-2012, 07:35 AM
Junior Member
Thread Starter
Join Date: Sep 2011
Posts: 2
Default

Mine was a pretty easy fix. There are a couple guide-bar-type-things that move when you open the trunk. Mine had some loose from the plastic piece that holds them in place as they turn when the trunk is opened, and it touched the magnet of the speaker. When it did that, the amp would cut off. It even got to the point where the trunk wouldn't open, but it was an easy fix. Just put it back in the plastic holder.

Hope this helps.
 
  #5  
Old 02-25-2012, 08:06 AM
Junior Member
Join Date: Feb 2012
Posts: 7
Default

Had the same problem in the trunk with mine but; that didn't fix the problem for me. My amp actually "went up in smoke", and the cabin smelled like burning electronics,

Still trying to find a used one from salvage yards but; so far no luck
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Snoopyd
General Tech
1
05-12-2015 11:45 AM
lonewolf41
Audio/Visual Electronics
7
05-10-2014 12:36 AM
tnsparky
Audio/Visual Electronics
2
03-20-2013 10:44 AM
paulpingpong
ECU & Electronics
5
07-31-2008 11:25 AM
blown5.0
General Tech
3
07-24-2007 06:32 PM


Thread Tools
Search this Thread
Quick Reply: Amp went out in 2007 Camry w/ JBL System


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.