DIY - Do It Yourself Within you will find how-to's on many aspects of modding and caring for your ride as told by your fellow members.

Temp gauge reads half even when cold??

  #1  
Old 10-29-2012, 03:32 AM
Junior Member
Thread Starter
Join Date: Oct 2012
Posts: 1
Question Temp gauge reads half even when cold??

Hi guys i just bought a 1999 3.0 V6 Camry and the temp gauge never reads cold on it as soon as i start the ignition it rises to half way and stays there ive been keeping an eye on the temp of the engine and it doesnt over heat put im worried if it does the gauge wont show it.

I have tried disconnecting the temp sender and it still stays at half have any of you came across this problem before?

thanks in advance
Conor
 
  #2  
Old 10-29-2012, 09:43 PM
Super Moderator
Join Date: Jan 2008
Location: PTW
Posts: 11,738
Default

You disconnect the right sender, there is more then one?

Might be Yellow/Green wire.

There is also a Brown colored ground wire going to the gauge behind the meter console. Could be the ground point is bad causing higher ohm resistance but just a guess.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
cfcamry
General Tech
10
09-19-2008 03:07 PM
sammo
General Tech
6
08-08-2008 07:19 PM
vin888
ECU & Electronics
4
03-06-2008 08:39 PM
saxman
General Tech
2
10-03-2007 11:06 PM
tg305
General Tech
1
11-05-2006 01:24 PM


Thread Tools
Search this Thread
Quick Reply: Temp gauge reads half even when cold??


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.