TCF Help & Suggestion Center Need help with Toyota Camry Forums? Ask. Have a suggestion to better TCF? Tell us here.

1997 Camry 3.0 v6 won"t run. Help!

  #1  
Old 03-24-2016, 02:09 AM
Junior Member
Thread Starter
Join Date: Mar 2016
Posts: 2
Default 1997 Camry 3.0 v6 won"t run. Help!

My daughter has a 97 Camry LE 3.0 v6, when she bought the car, it had a slight rough idle, scanner showed multiple misfires. We thought coil packs. She drove it a few days, it would cut off sometimes at stops, but it would restart, until last time. Found engine had hardly any compression on #3. Replaced engine, put in new packs, timing belt, water pump, injectors, plugs etc.

Engine will idle when cold, then shut off. Scanner give no codes. If throttle is held between 2500 to 3000 rpm, engine will run all day, but try to go higher or lower, engine shuts off. We have replaced engine computer, MAF, cam, crank, temp sensors. Cleaned throttle body, idle air control, plugs & wires, fuel pump pressure good, injectors working good, etc. We are at a loss.

Any suggestions would be most welcomed.

Thanks
 
  #2  
Old 03-24-2016, 10:30 PM
Super Moderator
Join Date: Jan 2008
Location: PTW
Posts: 11,739
Default

Did you replace the complete engine including throttle body, injectors, sensors, etc. Or use a short block or swap parts with old engine?
 
  #3  
Old 03-25-2016, 11:09 AM
Junior Member
Thread Starter
Join Date: Mar 2016
Posts: 2
Default

Originally Posted by toyomoho View Post
Did you replace the complete engine including throttle body, injectors, sensors, etc. Or use a short block or swap parts with old engine?
Complete engine, and yes everything has been replaced. When you first start it up cold, it will idle for about 2mins then shut itself off. It will start again with foot on the gas will give a slight backfire and will run all day between 2500- 3000 rpms any more it will cut off, any less it will cut off.
 
  #4  
Old 03-25-2016, 06:08 PM
Super Moderator
Join Date: Jan 2008
Location: PTW
Posts: 11,739
Default

A few places to start:

The cars computer is specific to the engine as to year, emissions and transmission. Make sure any sensors, controls, etc. on the new engine are the same as the old engine.

Recheck all wiring to the engine plus make sure all plug wire connections are good.

Backfiring through the engine intake is typically a fuel problem. Check for fuel issues such as failing pump, plugged fuel filter or line (the can filter in the engine seldom plugs up but?), bad fuel in tank, etc.

Some engines have a control to boost fuel pressure when cold starting. If the old engine had this make sure the new engine also has.

Low electrical voltage and current can cause engine issues. Check battery and alternator output, battery connections and terminals, wire ground points, etc.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
predsd
General Tech
2
02-26-2016 05:57 PM
FireTiger7
General Tech
3
06-08-2014 05:19 PM
rixemailfl
General Tech
3
08-07-2011 02:39 PM
peterliu2000
General Tech
4
08-11-2010 11:15 PM
nitroman0640
General Tech
1
09-15-2008 07:28 PM


Thread Tools
Search this Thread
Quick Reply: 1997 Camry 3.0 v6 won"t run. Help!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.